请选择 进入手机版 | 继续访问电脑版

安富莱电子论坛

 找回密码
 立即注册

扫一扫,访问微社区

查看: 137|回复: 6
收起左侧

[STemWin] 我用103VET移植的STemwin跑DEMO的时候,卡在一个界面不动,是什么鬼

[复制链接]

20

主题

68

帖子

108

积分

初级会员

积分
108
发表于 2019-1-31 11:08:22 | 显示全部楼层 |阅读模式
我用103VET移植的STemwin跑DEMO的时候,卡在一个界面不动,是什么鬼
回复

使用道具 举报

20

主题

68

帖子

108

积分

初级会员

积分
108
 楼主| 发表于 2019-1-31 11:17:39 | 显示全部楼层
GUI_TIMER_TIME GUI_X_GetTime(void) {
  return OS_TimeMS;
}

void GUI_X_Delay(int ms) {
  int tEnd = OS_TimeMS + ms;
  while ((tEnd - OS_TimeMS) > 0);
}
卡在了这个函数里面
回复

使用道具 举报

2

主题

9

帖子

13

积分

新手上路

积分
13
发表于 2019-1-31 12:59:20 | 显示全部楼层
你的OS_TimeMS值是从哪里获取的, 在中断中累加?如果是嵌入系统的话最好调用系统的延时函数
回复

使用道具 举报

20

主题

68

帖子

108

积分

初级会员

积分
108
 楼主| 发表于 2019-1-31 13:46:32 | 显示全部楼层
xinxinsky 发表于 2019-1-31 12:59
你的OS_TimeMS值是从哪里获取的, 在中断中累加?如果是嵌入系统的话最好调用系统的延时函数

延时,就是STemwin自己带的,我把这个改成滴答函数也是一直在这里面,应该不是这边的问题,就是一直卡住不往下走
回复

使用道具 举报

5276

主题

3万

帖子

4万

积分

管理员

做人第一,工作第二

Rank: 9Rank: 9Rank: 9

积分
42678
QQ
发表于 2019-2-1 00:05:24 | 显示全部楼层
跑的什么Demo,emWin自带的那个综合的吗

简单的跑个对话框添加几个按钮测试就可以。
淘宝小店: https://armfly.taobao.com/
专注,努力,用心的做好每一件事情,Fighting!
回复

使用道具 举报

2

主题

9

帖子

13

积分

新手上路

积分
13
发表于 5 天前 | 显示全部楼层
把工程贴上来吧
回复

使用道具 举报

20

主题

68

帖子

108

积分

初级会员

积分
108
 楼主| 发表于 5 天前 | 显示全部楼层
谢谢,问题已经解决了,主要是在滴答中断里没有添加OS_TimeMS ++;  导致延时不正常,我用的是ST给的那个DEMO
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|小黑屋|手机版|安富莱电子论坛 ( 鄂ICP备09023347号,公安机关备案号42010602000201 )

GMT+8, 2019-2-19 17:35 , Processed in 0.178217 second(s), 25 queries .

Powered by Discuz! X3.4 Licensed

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表